Migrate Plesk to MariaDB 10.1

Migrating Plesk to MariaDB 10.1 is fairly simple, currently Plesk officially supports up to MariaDB 10 and MySQL 5.6 (since writing 10.1 is now supported), so this is “use at your own risk”. I’ve run Plesk with MariaDB 10.1 on various operating systems, here I’ll show you how to install on Ubuntu 14 LTS from the MariaDB repository…

Please Note: An in place upgrade like this does not work on Ubuntu 16, you need to install MariaDB prior to installing Plesk, though I will be coming back to this issue when I have time.

Preperation

1. Import the key

2. Add the repository

3. Now update apt…

4. Stop the current MySQL/MariaDB process (if you use WatchDog to monitor MySQL/MariaDB stop monitoring first)

And

Installation

5. Install like so…

If prompted to set a password, leave blank to keep your current, and you should over write the my.cnf file with the latest version to make sure you get all the optimizations added for MariaDB, especially if you are coming from MySQL.

Final Stage

6. Now you can start the MySQL service and start Watchdog monitoring…
Stop the current MySQL/MariaDB process (if you use WatchDog to monitor MySQL/MariaDB stop monitoring first)

And

Should you have any problems, please see the notes at the bottom of my post on Migrating Plesk to MariaDB

Updating the Kernel on Ubuntu

You can update Ubuntu to the latest kernel very easily using apt-get.
To generate a list of available kernels run…

This will create an extensive list on Ubuntu 14.04 LTS, so I have picked out the latest to give three examples…

Depending on which version you would like to install, run one of these commands…

linux-image-3.19.0-58-generic…

linux-image-4.2.0-35-generic…

linux-image-4.4.0-21-generic…

And reboot your server.

You can then run…

To clean up any old images, it may not find any right away, but you will be reminded at a later date.